CSA CAN/CSA-ISO/IEC 21000-17:07 (R2022)

Current Reaffirmation
Information technology - Multimedia framework (MPEG-21) - Part 17: Fragment Identification of MPEG Resources (Adopted ISO/IEC 21000-17:2006, first edition, 2006-09-15)

Best Price Guarantee Jan 1, 2007 English 1 Pages

Sub Total (1 Item(s)) $ 0.00
Estimated Shipping $ 0.00
Total (Pre-Tax) $ 0.00

You own the digital copy of this edition

View in Library
or
Canadian Standards Association Logo

CSA CAN/CSA-ISO/IEC 21000-17:07 (R2022)

Information technology - Multimedia framework (MPEG-21) - Part 17: Fragment Identification of MPEG Resources (Adopted ISO/IEC 21000-17:2006, first edition, 2006-09-15)

PUBLISH DATE 2007
CSA CAN/CSA-ISO/IEC 21000-17:07 (R2022)
Information technology - Multimedia framework (MPEG-21) - Part 17: Fragment Identification of MPEG Resources (Adopted ISO/IEC 21000-17:2006, first edition, 2006-09-15)
Scope
1.1 General

This International Standard is titled "Fragment Identification of MPEG Resources" and specifies a normative syntax for URI Fragment Identifiers to be used for addressing parts of any resource whose Internet Media Type is one of

  • audio/mpeg [RFC3003];
  • video/mpeg [RFC2045, RFC2046];
  • video/mp4 [RFC4337];
  • audio/mp4 [RFC4337];
  • application/mp4 [RFC4337]. MPEG URI Fragment Identifier schemes offer comprehensive and flexible mechanisms for addressing fragments of audiovisual content. Therefore, their use may potentially be extended to other audiovisual Internet Media types. Such URI Fragment Identifiers are compliant to the generic syntax for URIs defined by IETF RFC 3986 and therefore can be used after the "#" character in a URI. Where appropriate, such Fragment Identifiers can also be used in IRIs as specified by IETF RFC 3987. The syntax for URI Fragment Identifiers defined in this specification is based on the W3C XPointer Framework Recommendation and adds the ability to address:
  • temporal, spatial and spatiotemporal locations of a resource;
  • logical units of a resource according to a given Logical Model;
  • byte ranges of a resource;
  • items or Tracks of an ISO Base Media File;
  • a portion of a video through the use of a Mask
Loading...

Failed to load document history.

Publish Date Document Id Type View